Back to overview
Resolved

Intermittent Dashboard Errors

Jul 9, 2026 at 7:30am UTC
Affected services
App
Widgets

Resolved
Jul 9, 2026 at 7:30am UTC

Investigating — intermittent errors

We’re seeing brief, intermittent 504 errors affecting a small number of
requests. The platform remains operational and the majority of bookings,
payments and dashboard activity are unaffected — if you do hit an error, a
refresh should resolve it.

We’re monitoring closely and investigating the cause. We’ll post a further
update later today.